yarn installでこれが出たら「eslint-config-react-app@2.1.0" has incorrect peer dependency "eslint@^4.1.1」

yarn installでこれが出たら「eslint-config-react-app@2.1.0″ has incorrect peer dependency “eslint@^4.1.1」

yarn installでこれが出たら「eslint-config-react-app@2.1.0″ has incorrect peer dependency “eslint@^4.1.1」

please see document

There is a writting as section
「out side creat-react-app」

according to it,

npm install –save-dev eslint-config-react-app babel-eslint@^7.2.3 eslint@^4.1.1 eslint-plugin-flowtype@^2.34.1 eslint-plugin-import@^2.6.0 eslint-plugin-jsx-a11y@^5.1.1 eslint-plugin-react@^7.1.0

In my case I was using 3.1 of eslint

so,

yarn installでこれが出たら「eslint-config-react-app@2.1.0" has incorrect peer dependency "eslint@^4.1.1」

yarn installでこれが出たら「eslint-config-react-app@2.1.0″ has incorrect peer dependency “eslint@^4.1.1」

make sure eslint version in package.json


rm -r node_modules

yarn install

(Visited 1 times, 1 visits today)