【Gatsbyjs develop/yarn develop】解決(resolve) 「node_modules/gatsby-cli/node_modules/yoga-layout-prebuilt/yoga-layout/build/Release/nbind.js:53」

【Gatsbyjs develop/yarn develop】解決(resolve) 「node_modules/gatsby-cli/node_modules/yoga-layout-prebuilt/yoga-layout/build/Release/nbind.js:53」

これが出たら、

/usr/local/lib/node_modules/gatsby-cli/node_modules/yoga-layout-prebuilt/yoga-layout/build/Release/nbind.js:53
        throw ex;
        ^

Error: listen EADDRNOTAVAIL: address not available 127.0.0.3:8000
    at Server.setupListenHandle [as _listen2] (net.js:1296:21)
    at listenInCluster (net.js:1361:12)
    at GetAddrInfoReqWrap.doListen (net.js:1500:7)
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:8)
Emitted 'error' event on Server instance at:
    at emitErrorNT (net.js:1340:8)
    at processTicksAndRejections (internal/process/task_queues.js:84:21) {
  code: 'EADDRNOTAVAIL',
  errno: 'EADDRNOTAVAIL',
  syscall: 'listen',
  address: '127.0.0.3',
  port: 8000
}

how to resolve

If this appears, please set the version of gatsby and the version of gatsby-cli to node 12.18.3

If you installed with npm, uninstall them with npm and reinstall with yarn add
So if you make a project, delete it for the time being
It is better to recreate them with gatsby new in those versions

afterwards
packge.json also reversion to those versions

gatsby build
gatsby develop(yarn develop)

gatsbyのversionとgatsby-cliのversionを合わせてnodeは12.18.3にしてください

npm でinstallした場合はそれらをnpm uninstall して、yarn add でインストールし直し
それでプロジェクトを作ったらとりあえず消して
それらのバージョンでもう一度 gatsby newで作り直した方が良いです

その後
packge.jsonもそれらのversionにし直し

gatsby build
gatsby develop(yarn develop)

Gatsbyjs develop/yarn develop時にエラー。やったことまとめ

確認 node -v

v12.18.3

gatsby -v

gatsby -v にしたとき、下記のバージョンじゃない場合エラーが出ます。両方最新の時など。

Gatsby CLI version: 2.12.21
Gatsby version: 2.22.12

それぞれになるようにします

なのでcliをグローバルインストールした場合uninstallして
バージョン指定で再インストールする(npm i -g ではなくyarnで)

yarn global add gatsby-cli@2.12.21
package.jsonに記述している
gatsbyもバージョンを変更して

rm -rf node_modules
して全部消してから
yarn install

もう一度
gatsby -v
して

Gatsby CLI version: 2.12.21
Gatsby version: 2.22.12

になるか確認

その後

yarn build

yarn devlop

【Gatsbyjs develop/yarn develop】解決(resolve) 「node_modules/gatsby-cli/node_modules/yoga-layout-prebuilt/yoga-layout/build/Release/nbind.js:53」

なんか上の方でえらっているけど、localhost動くからとりあえずオッケー

https://github.com/gatsbyjs/gatsby/issues/24577

全面解決はこれをウォッチしていればok


「武骨日記の」プライバシーポリシーに関して
プライバシーポリシー
個人情報取り扱いに関して

サイトTOP
私は何者か
29歳よしもと芸人がWebデザイナー未経験で学校に通い5年後フリーランスのフロントエンドエンジニアになるためにやった9つのこと
フロント記事
フロントエンドエンジニア
フロントエンド記事(タグ)
TypeScript
TypeScript練習問題集
【TypeScript】TypeSript中級者になる為に知っておくと良い108個のこと
JavaScript練習問題
styled-componentsの使い方
SCSS問題集
GraphQL「Apollo x Relay-Style-Cursor-Pagination(リレースタイルカーソルページネーション)」
recomposeと仲良くなりたい
機動戦士FlowType
初めてReactNativeWebを触ってみて
Ramda.jsシグネチャの読み方
環境変数の話
いちごタルトの作り方
フロントエンドエンジニア豚汁の作り方


「武骨日記の」プライバシーポリシーに関して
プライバシーポリシー

株式会社TerraceTechについて
最近起業しました。
株式会社TerraceTech

SNS
インド旅 instagram
適当な日常写真 instagram
シュールさーん instagram
シュールさーん LINEスタンプ
もりたけんじTwitter
ネタ帳Twitter
note

FaceBook -kennji.morita-

わたしが結成しているWebチームではWeb未経験者、フリーランスの方へのお仕事を紹介しています。
また個人レッスンしてほしい生徒も募集中です。
もしご興味ある方はチャットからご連絡ください。

※業務連絡やお久しぶり連絡もチャットからお願いします。