スクリーンショット 2016-07-05 21.56.12

【postcss-cssnext】Container#eachDecl is deprecated. Use Container#walkDecls instead.

Container#eachDecl is deprecated. Use Container#walkDecls instead.

eachDeclは廃止されたので代わりにwalkDeclsを使え

var opacity = function (css, opts) {
    css.eachDecl(function(decl) {
        if (decl.prop === 'opacity') {
            decl.parent.insertAfter(decl, {
                prop: '-ms-filter',
                value: '"progid:DXImageTransform.Microsoft.Alpha(Opacity=' + (parseFloat(decl.value) * 100) + ')"'
            });
        }
    });
};
gulp.task('css', function () {
    var processors = [
        cssnext({browsers: ['last 2 version']})
        //ここ
    ];
    return gulp.src('./src/*.css')
        .pipe(postcss(processors))
        .pipe(gulp.dest('./dest'));
});

いったんチュートリアルのまるまるもってきたから、その時のバージョンと現在の差異があるらしい、とりあえずopacityは使わないし、バージョンアップも激しいだろうから一旦、上記「ここ」でopacityをタスクとから外したなくした(解決にはなっていない)

ここでみんな騒いでいる

 

 

(Visited 3 times, 1 visits today)