スクリーンショット 2015-01-02 12.57.54

Eclipseでこのようなエラーが出たら。Error: Most middleware (like bodyParser(ここ)) is no longer bundled with Express and must be installed separately. Please see https://github.com/senchalabs/connect#middleware.

Eclipse
このようなエラーが出てたら

Error: Most middleware (like bodyParser(ここ)) is no longer bundled with Express and must be installed separately. Please see https://github.com/senchalabs/connect#middleware.
at Function.Object.defineProperty.get (/Users/No51/node_modules/express/lib/express.js:89:13)
at Object. (/Users/No51/Desktop/Git/workspace/myexapp/app.js:22:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
at startup (node.js:119:16)
at node.js:906:3

ここにいって確認
https://github.com/senchalabs/connect#middleware
スクリーンショット 2015-01-02 13.02.13

previouslyは(以前の)という意味

なにをいっているかというと
npmのバージョンが上がって使っているモジュールが新しくなったからこっち使え。こういう風につかえって書いてある。。
そのためにはwinならコマンドプロンプト
macならターミナルで
モジュールをインストールして
、呼び出し方を変えて
実行関数を変える
んでnode.js実行。

そうするとエラーの内容が変わって、また変えろみたいになるから
そしたらリファレンスから古くなったモジュールあるか確認して同じことをする

このエラー解決するのに4時間掛かったからね。正月返して欲しい。。駅伝の往路見ずにだからね。もう一回走って欲しい。。

他にもここ参照した
http://qiita.com/nextfactory/items/476c5150268e2c7db4ec

スクリーンショット 2015-01-02 12.57.54

(Visited 5 times, 1 visits today)

コメントを残す

メールアドレスが公開されることはありません。