【Webpack/babelrc/babel-loader】これが出たら。Module build failed: ReferenceError: [BABEL] [filePath] Unknown option: ./index.js.babelrc.preset

【Webpack/babelrc/babel-loader】これが出たら。Module build failed: ReferenceError: [BABEL] [filePath] Unknown option: ./index.js.babelrc.preset

【Webpack/babelrc/babel-loader】これが出たら。Module build failed: ReferenceError: [BABEL] [filePath] Unknown option: ./index.js.babelrc.preset

【Webpack/babelrc/babel-loader】これが出たら。Module build failed: ReferenceError: [BABEL] [filePath] Unknown option: ./index.js.babelrc.preset

【Webpack/babelrc/babel-loader】これが出たら。Module build failed: ReferenceError: [BABEL] [filePath] Unknown option: ./index.js.babelrc.preset


ここに
https://github.com/babel/babel-loader/issues/132#issuecomment-223110041

書いてあるように
babel-loaderとbabelとbabel-preset-es2015とbabel-coreのバージョンを確かめる。
babel5とbabel6では解析が違う

やること
package.jsonのバージョンがそれぞれ互換性があるか確認。
babel関係のpackageバージョン指定を一回消して(もしくはupdateするnpmのコマンド打ったり)
個別に再度新しいバージョンでインストールを検討してください。
私は下のpackage.jsonをnpm i して使っていてエラーが出た。

{
"name": "bukostu",
"scripts": {
"start": "webpack-dev-server",
"build": "webpack"
},
"devDependencies": {
"babel-core": "^5.8.33",
"babel-loader": "^5.3.3",
"file-loader": "^0.8.4",
"webpack": "^1.12.2",
"webpack-dev-server": "^1.12.1"
},
"dependencies": {
"react": "^0.14.1",
"react-dom": "^0.14.1"
}
}

これを下記のように修正したら治った。

{
"name": "bukostu",
"scripts": {
"start": "webpack-dev-server",
"build": "webpack"
},
"devDependencies": {
"babel": "^6.5.2",
"babel-core": "^6.18.2",
"babel-loader": "^6.2.8",
"babel-preset-es2015": "^6.18.0",
"file-loader": "^0.8.4",
"webpack": "^1.13.3",
"webpack-dev-server": "^1.12.1"
},
"dependencies": {
"babel-polyfill": "^6.16.0",
"react": "^0.14.1",
"react-dom": "^0.14.1"
}
}

(Visited 1 times, 1 visits today)